Saturday, November 10, 2012

Geopaparazzi 3.3.0 is out: free you painting artist heart!

We just released Geopaparazzi 3.3.0 in the market.

There are a couple of enhancements and a feature I think most people will like.
The is version's changelog is the following:
  • added sketch pad for forms(the feature I think most people will like)
  • added textarea for forms
  • move export folder outside of geopap folder
  • fixed OSM notes info
  • sms are now sent through the system app
  • better geocoding
  • better about window 
Let's give some more info about those that need...

1) the sketch pad

If you browse through the menus, you will note that you are now able to add a new type of note:





and also when you add notes without gps:


Well, you now can add finger drawn sketches as notes to your map. For now the sketch pad is quite simple, it allows for some colors and some line widths. But it also has.... UNDO/REDO capabilities!! I really want to thank Almond Mendoza for his tutorials on creating a nice sketch pad.
An example? Assume you are an engineer that needs to create a quick schema of what he sees inside a manhole:


Just draw it, save it and it is on your map!



2) geocoding 

In the geocoding part, the routing gui has been cleaned up to have a better user experience. Remeber that narrow gui, where on small screens you were not even able to read the results? Yeah, that one.





3) sms sending

A user reported that the sms were sent without considering special offers they have with their carriers. So if seems that direct sending of sms goes through an extra channel.

Therefore for all geo-sms message sending we now popup the system's sms application, so the user can decide to add some text and decide the destination.

For the panic button, since when we use it we are happy to pay those few cents if it happens, we left the automatic, one tab sms sending.


Well, that is more or less it.
Enjoy!


one sad PS: this was the last version supporting android 2.2. With the next release NFC will get into the library, which will require android 2.3+. I am sorry about that, but we need to keep moving with the innovating parts.




Post a Comment